THEROTHERHAMKID

Impreza 1.5 poor mpg

Recommended Posts

Just looking at getting the missus one of the 1.5ltr engines sld the clio Fucking horrid bit of shit them cars :laugh: I could only manage about 30.4 MPG out of the. As said above AWD system is heavy but was hoping to see a bit better mpg well around the clio I'd be happy. 

 

As for the filter I'm unsure until I've seen one.  

Share this post


Link to post
Share on other sites
26 minutes ago, Jamie_uk said:

It's a drop in filter so it'll need to be same size as original 

It's not a panel filter I want it's the cone type I want induction type 

Share this post


Link to post
Share on other sites

Let me know if you find one. I got advised to use panel filter far as I know there isn't a cone for the 1.5 or 2.0 . Looked for ages never ever found one. Think couple other guys had tried too they advised me to panel it. And it has improved airflow.

halfords do a universal cone for £20 . K&n do one think it's Apollo which is universal. 

Problem I found was the kits for Subarus have a completely different intake pipe and mount which won't fit. 

Share this post


Link to post
Share on other sites

Sure be a way to make induction kit fit. I'd have to look at the 2.0 pipe work if it's the same though I can't see why not.  

Share this post


Link to post
Share on other sites

I think it small engine big car syndrome. 

I can manage near 40MPG i think on a long motorway drive if i remove my roof rack and eco drive the hell out of it.

Normal driving its around 25-30 MPG i think. I'll work it out next time i fill up and dont quote what i said as ive just pulled those numbers out my head from a while back.

I'd say run some redex through it as that seemed to help mine out a bit.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Razz311 said:

I think it small engine big car syndrome. 

I can manage near 40MPG i think on a long motorway drive if i remove my roof rack and eco drive the hell out of it.

Normal driving its around 25-30 MPG i think. I'll work it out next time i fill up and dont quote what i said as ive just pulled those numbers out my head from a while back.

I'd say run some redex through it as that seemed to help mine out a bit.

Ok will run some redex through it cheers 

do you know of a aftermarket filter for the 1.5 other than replacement panel? 

 

 

Share this post


Link to post
Share on other sites
23 hours ago, Gambit said:

Sure be a way to make induction kit fit. I'd have to look at the 2.0 pipe work if it's the same though I can't see why not.  

Did you check pipe work? Surely there's a way to fit a induction filter just has to have fitting for air sensor 

Share this post


Link to post
Share on other sites
11 hours ago, THEROTHERHAMKID said:

Ok will run some redex through it cheers 

do you know of a aftermarket filter for the 1.5 other than replacement panel? 

 

 

No clue for a aftermarket filter I'm afraid, I'm just using the stock panel.

Share this post


Link to post
Share on other sites
40 minutes ago, THEROTHERHAMKID said:

Did you check pipe work? Surely there's a way to fit a induction filter just has to have fitting for air sensor 

Not had chance yet mate. But I'll only be able to use google. Not bought the car yet just sold my missus car waiting for payment from that first. :happy:

Share this post


Link to post
Share on other sites

I can go grab a quick pic of what mine has if that would be any help to you?

Share this post


Link to post
Share on other sites

You can make anything fit if you are determined enough - check out some the project threads.

The intake will meet the alloy cast piece leading to the throttle body, get that jubilee clip off and measure the diameter at that point. From then you will need a selection of silicon hose pieces, alloy / steel tubing and your universal aftermarket filter. mounting the MAF will need to be addressed either by using your original pieces and combining with your aftermarket stuff or making a mount in one of the metal tubes. I would go for the latter as you keep your original scoob stuff so you have a fall back option.  

Share this post


Link to post
Share on other sites
On 2/12/2020 at 10:20 PM, Steven091 said:

I've recently got the 2.0 rx and it sit at I've put 50 pound in the tank 104 miles done defo something wrong no?

Depends how you drive and where - did you rest the ave mpg indicator, what is that reading?

What fuel did you put in?

How many miles on clock?

When was last service?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...