Denver05

Possible immobilizer problem

Recommended Posts

Hello.I have a unusual problem... Saturday evening after I finished my work I went to my car unlocked the car and left my backpack in it , locked the car using the key remote button.all good...I returned to my van, finished some paperwork..after I finished,came back to my car... nothing.i couldn't unlock the doors using my remote key button...I did it manually and the car didn't start...I presumed is the key battery was dead.i opened the key, took the battery out and went to a few nearby shops trying to find a battery.i found one,replace it...and nothing.same problems...I brought another battery, hopping the first one was a"new old" battery... nothing...I don't have the 4 digits code...I don't have another key...I presume the sync between immobilizer and the key is gone( kept to long the key without the battery) so I called 2 car locksmiths...they asked me about that code which I don't have...I went back toy car today...I measured the car battery..12.8v..all good...I called AA recovery man.i was hoping he will sync the key with the car but he couldn't.We started the car by bump start...did start alright...soon as I turned the engine off...same problem...I don't know what to do next.i will appreciate any ideas. Thank you

Share this post


Link to post
Share on other sites
 

Subaru dealer should be able to provide the 4 digit code if it's a standard UK Sigma alarm. Just prove to them you're the owner (V5 etc).

On the current problem, try disconnect the car battery for about 30 minutes. If the alarm sounds immediately, try the remote button (may help if it's close to the car). If no alarm sound, depress the brake pedal a couple of times to bleed any residual current, then reconnect the car battery. Then try the key button,

Share this post


Link to post
Share on other sites

Thanks Greenmamba.i will try that too..but I can't think only to on thing...if is the immobilizer is  faulty..or the immobilizer doesn't recognise the key...why the hell I could bump start the car? Is not that secure then.lol...i don't say anything...I was able to bring the car home.🤘👍 

Share this post


Link to post
Share on other sites

Update.works fine now.i received the pin from Subaru dealers ( £24 ) and I reprogramed the key following the steps in manual.is all good now.thank you all for the support 🎉🤘

All the best

15136885429781204842563.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now