Sign in to follow this  
Stevieb_08

Reeee noise on boost

Recommended Posts

Just had the engine out of my 2006 impreza Sti to do the head gaskets (shock). It is now refitted to the car and I'm experiencing a reeeee sounding noise at about 0.4 Bar, getting louder up to 1.1 Bar where the boost limit is hit. 

I also have code P2021 "Intake runner position sensor/switch low bank 2 c" showing but disappears and stays off for the duration of the drive when reset, but the reeee noise was there from the moment the engine was boosted the first time, where as the code didn't appear until after the MOT last weekend. As far as I'm aware the garage didn't touch the engine. Previously it was showing the same code but on bank 2 a, but this was sorted by installing the sensor correctly as I hadnt previously.

Anyone have any ideas on what the noise could be and if its related to the code, and if there is a sensor c on the ej257 intake runners/TGVs? All hoses are tight and ftted correctly around the intercooler and turbo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this