ade

Head unit upgrade

Recommended Posts

Has anyone had any success in upgrading the head unit in their XV's? If so where did you get a harness to connect the two together from?

I bought a Kenwood last week, with a harness kit which when I've opened up the dash, removed the old stereo unit and tried to connect it up doesn't fit, there are several connectors not there on the new harness.

I'd tried getting my Subaru dealer to price me up an upgrade but they still haven't done it, has taken them three weeks to let me know when the recall kit will be in for the other outstanding work

Thanks in advance 

Ade

Share this post


Link to post
Share on other sites

In the harness adaptor did you get the steering wheel control loom as well?

Share this post


Link to post
Share on other sites
On 7/8/2019 at 3:36 PM, Jay762 said:

In the harness adaptor did you get the steering wheel control loom as well?

No there wasn't one available which fitted and when I have looked online nothing seems to meet the spec\criteria. 

I've just been to my local mechanic who says he may be able to source one.

 

Share this post


Link to post
Share on other sites

that sounds positive - hopefully he can hook you up

Share this post


Link to post
Share on other sites
On 7/11/2019 at 6:07 AM, Jay762 said:

that sounds positive - hopefully he can hook you up

So he wasn't able to, and my Subaru dealer wasn't much help either today when it was in for 2 more recalls ( thats 3 this year)

I've found a company called Accutek in Winchester who I spoke to today and they reckon they can order the cables in for me..So I've placed the order and should have them by next friday

  • Like 1

Share this post


Link to post
Share on other sites

So todays update is the wiring harness they got me doesn't fit, they have suggested that maybe the connectors I am seeing are a wiring harness extension and that I should chase the loom back to see if it has been extended.. What really should have been an easy 30 minute job is turning into way too much hassle.. and when I chased the wiring back I can't find any extensions being made..

 

Share this post


Link to post
Share on other sites

@Ade,

Sounds more like they got you the wrong cable, I feel for you.  Maybe try and photograph the cables you have to help the company who supplied the harness identify a correct version?

Share this post


Link to post
Share on other sites
7 hours ago, ernieb said:

@Ade,

Sounds more like they got you the wrong cable, I feel for you.  Maybe try and photograph the cables you have to help the company who supplied the harness identify a correct version?

I took a photo in and the guy went through his database of cables available for the XV and none of them look like it, I've attached a pic below showing all of the cables which attach to the back of the stereo circled in Red.. 

I'll give them a call on Tuesday and see what they suggest next other than they fit it for me, tbh at the moment I'm even tempted to do that.

dash.jpeg

Share this post


Link to post
Share on other sites

It might, in the end, be the best option to let them sort it for a fixed price.  if it does not work you don't pay and they will sort any issues with coding (if required)

  • Like 1

Share this post


Link to post
Share on other sites

So the XV spent two hours with Accutek today and the stereo still isn't fitted as they didn't have all the cables in stock, they have done all the prep work including fitting the mic, Dab aerial, harness and grinding the screws off the mounting frame as the screws were so tight they wouldn't come out with a screwdriver. Hopefully goes back next week once the cables are in stock for 30 mins to finish the install.Once I've got the list of parts needed I'll stick them on here for anyone who wants to try it.

 

Share this post


Link to post
Share on other sites

At least there's progress and you can see the end in sight?

  • Like 1

Share this post


Link to post
Share on other sites

So finally it is in and 80% working, they described the car as a Bitsa, as it has bits of this and bits of that in the wiring loom. They have done several XV's and other Subaru's and never had the problems they have faced with this one. They ended up taking parts of wiring harnesses from different makes to get all of the steering wheel connections to work. 

The bit that doesn't work is the reversing camera, apparently the original camera will not work with any aftermarket stereo, which I find hard to believe so will do some other research.

Looking at the receipt the bits I needed on top of the Stereo were as follows:

29-709 Subaru SWC
C2 CT-27AA78 Toyota 2009 Aerial Adaptor
CT SSU002-2
C2 CT-Multilead Universal Patch lead
ICT 70-923 DAB +3db Windscreen Mount

I think they also provided a Toyota Facia surround which they don't appear to have charged me for.

  • Like 1

Share this post


Link to post
Share on other sites

@ade 

sounds like you are overall happy with what’s been achieved, pity the reversing camera is not functioning, sounds weird as you’ve indicated. 

Enrie

Share this post


Link to post
Share on other sites
1 hour ago, ernieb said:

@ade 

sounds like you are overall happy with what’s been achieved, pity the reversing camera is not functioning, sounds weird as you’ve indicated. 

Enrie

Yes Ernie overall happy, and more importantly the wife is 😉

And hopefully the info will be of use to anyone else trying to do an upgrade in future.

Share this post


Link to post
Share on other sites
On 7/6/2019 at 7:31 PM, ade said:

Has anyone had any success in upgrading the head unit in their XV's? If so where did you get a harness to connect the two together from?

I bought a Kenwood last week, with a harness kit which when I've opened up the dash, removed the old stereo unit and tried to connect it up doesn't fit, there are several connectors not there on the new harness.

I'd tried getting my Subaru dealer to price me up an upgrade but they still haven't done it, has taken them three weeks to let me know when the recall kit will be in for the other outstanding work

Thanks in advance 

Ade

So it sounds like we have been going through this at the same time, I've been waiting 3 weeks for a fitting kit from Halfords, only to find out it won't be in stock for the foreseeable. Anyway I contacted Dynamic sounds and was able to get the wires but not the facia, I used CTSSU002.2 with Additional Stereo patch lead CTMULTILEAD. 2, which was free. 

This allowed me to remove my old cd radio, and replace with a Sony Android auto unit. I also used a halfords DAB stick on areial. The reversing camera still functions on the upper screen, and steering wheel controls work, and are programmable from the head unit. Just needing to find a facia and work out why the DAB signal is so... Poor... 

 

Sorry I didn't read this a week ago else I might have been able to help. 

Share this post


Link to post
Share on other sites
31 minutes ago, Swayze88 said:

Just needing to find a facia

What facia is it as I have an aftermarket black plastic surround that I did not use in the end because the volume dial was too close - it may fit? 

Share this post


Link to post
Share on other sites
12 hours ago, Swayze88 said:

The reversing camera still functions on the upper screen, and steering wheel controls work, and are programmable from the head unit. Just needing to find a facia and work out why the DAB signal is so... Poor... 

When you say the reversing camera still works on the upper screen, do you mean the little one at the top which displays time, mpg, wheel rotation etc? mine has never shown it there.  

With regards to Facia, all he told me was that it was a Toyota, but I guess that was a Toyota one for a Kenwood stereo.

12 hours ago, Swayze88 said:

Sorry I didn't read this a week ago else I might have been able to help. 

No worries, I'm just happy to have got it sorted

 

Share this post


Link to post
Share on other sites
2 hours ago, ade said:

When you say the reversing camera still works on the upper screen, do you mean the little one at the top which displays time, mpg, wheel rotation etc? mine has never shown it there.  

With regards to Facia, all he told me was that it was a Toyota, but I guess that was a Toyota one for a Kenwood stereo.

No worries, I'm just happy to have got it sorted

 

Ah, yeah, the top panel multi function display has the reversing camera so didn't need to change that. 

How's the DAB signal in yours? Where did they put the aerial? Mine is on the front window passenger side (uk) and the signal is rubbish, making it unusable. 

15658535135256771732418696782298.jpg

Share this post


Link to post
Share on other sites

My DAB aerial is in the same location and signal is fine.

I dont think the surround will fit - ill dig out the reference number and you can check as I think it will be very close top and bottom

Share this post


Link to post
Share on other sites

Interesting reversing camera in that top display, nope mine def doesn't do that. Shame..

Attached Pics showing Stereo fitted and Dab aerial placement on the Passenger side. I get a good reception on it.

20190815_193204.jpg

20190815_193119.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...