Do Not Sell My Personal Information Jump to content

P0304 - Misfire cylinder 4


Recommended Posts

Hi, I need some help/information regarding this error code. First time I've had the engine management light pop up in my 2008 wrx, checked cylinder 4 and found whats on the pictures. Car has a big loss of performance below 3k but at higher rpm car seems to be normal. I have no overheating issues, oil seems fine and coolant is good too.

Please can anyone help with advice. Seems to some kind of foam thats build up on the piston, other cylinders are bone dry, just standard carbon build up. I did put some molybdenum in the car around 2 month when I last changed the oil and filter.

 

The car has around 91k miles on the clock. No mods and is standard map 226bhp.

20210111_171728.jpg

20210111_165958.jpg

Link to post
Share on other sites

Update from today.

 

The gunk has now gone, I have changed the spark plug in cylinder 4 still getting the error, I have also swapped the coil pack from cylinder 4 to 2 and 2 to 4. Still misfire in cylinder 4. No visible issues with piston or the head gasket using a endoscope.

 

Looking at checking the full wiring harness tomorrow, if that seems ok I'm going to get the injectors checked.

 

There is a lot of backfiring in the exhaust when idling or when releasing the throttle. Car pulls well above 3k rpm but there is a big loss of power under 3k rpm.

 

Does anyone know best the best place for the spark plug coils for a 2008 impreza wrx hatch? And are the coils coded for the cylinder?

Link to post
Share on other sites

Hi there, 

maybe worth doing a compression test on that cylinder 4 before getting involved with injectors and wiring? 
I believe the coils are not coded to each cylinder, but as you have swapped it with cylinder 2 doesn’t sound like a problem with the coil. 
 

hope it gets sorted anyway

Link to post
Share on other sites

Thanks for replying to my post. Struggling to get a compression done at the moment.

I did check the plug, coil pack and wire today for cylinder 4. Plug is sparking good. I also swapped injectors 2 and 4, still showing cylinder 4 misfires.

How the car is running I'm leaning towards it being an exhaust valve. The car is adding fuel at idle up to +18% short and +10% long was what I saw today, while waiting for the traffic lights to change while on a test drive.

The car will be SORN by the end of the month so trying to spend the bare minimum on it.

Cheers, Rich.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...