Search the Community

Showing results for tags 'front mount intercooler'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UK Subaru Owners Club
    • New Members Introductions
    • Discount Scheme
    • General Subaru Chat
    • Junk Room
    • Motorsport Chat
    • Subaru Gallery and Showroom
    • Subaru Members Area
    • Was it you?
    • Games/Console/Computer Nerd Room
    • Subaru Insurance Discussions
  • Subaru Clubs
    • Subaru Impreza Club
    • Subaru Legacy Club
    • Subaru BRZ Club
    • Subaru B9 Tribeca Club
    • Subaru Forester Club
    • Subaru Outback Club
    • Subaru XV Club
  • Subaru in General
    • Subaru Engines, Exhausts and modifications
    • Subaru Tyres / Wheels & Suspension
    • Subaru Audio / Electronics / Security
    • Subaru Interiors
    • Subaru Car Care
    • Subaru Servicing / MOT / Dealers
    • Subaru Build Threads
    • Subaru How-To Section
    • Subaru Parts & Accessories
  • Subaru Owners Club Meets
    • Car Shows
    • Regional Meets
  • Subaru Technical
    • Subaru How-To Guides
  • Subaru Marketplace
    • Member's Subarus For Sale
    • Subaru Parts For Sale
    • Subaru Group Buys
    • Subaru Parts Wanted

Categories

  • Subaru Impreza How-To Guides
  • Subaru Legacy How-To Guides
  • Subaru BRZ How-To Guides
  • Subaru Tribeca How-To Guides
  • Subaru Forester How-To Guides
  • Subaru Outback How-To Guides
  • Subaru XV How-To Guides

Product Groups

  • Converted Subscriptions
  • Premium Membership

Categories

  • Subaru Forum Videos
  • Subaru Impreza Videos
  • Subaru Forester Videos
  • Subaru Outback Videos
  • Subaru Legacy Videos
  • Subaru BRZ Videos
  • Subaru Modified

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location:


Interests


Subaru Model

Found 1 result

  1. I have installed a front mount inter-cooler on my99 turbo 2000 and a cone filter. The car is mafless however upon starting its idling and not running properly and putting out white smoke through the exhaust. It is hesitant to rev. What could this potentially be down to? Could it be the dumpy valve? Could it be that it needs a map again? Could it be anything else?