Jump to content

ej206 overheating


fernandos
 Share

Recommended Posts

hi, this is my first time coming to a forum so I'm not sure if I'm in the right department.

I have a Subaru Liberty 2002 B4 twin-turbo.

vehicle was driving fine till now.

it started overheating and I didn't let go of to the red on gauge cluster I shut the engine down.

the top radiator hose was very hot the bottom hose was cold i assumed the thermostat failed.

I replaced the thermostat the next day, started the car, and waited for the fan to come on,

the fan came on almost hitting the red on the gauge cluster.

shut the engine off and placed my hand on both radiator hoses, both were hot this time.

 I tested the fan and it passed, I assumed the Engine Coolant Temp ECU Sensor the 3 pins plug is faulty

so i checked the parts on our auto store called Supercheap Auto they have a really good online

catalog of parts for this vehicle. So I'm bit puzzled due to seeing 2 sensors  on their catalog

1 is called the Engine Coolant Temp ECU Sensor the other is called the Engine Coolant Fan Temperature Switch

i found the Engine Coolant Temp ECU Sensor but I can not locate the other.

now I'm not sure if the auto store has made a mistake.

does anyone know if there are 2 sensors if there are where is that sensor located?

thank you

Untitled.png

Untitled1.png

Link to comment
Share on other sites

18 hours later I got no help.

don't you all talk at once 🙂

1-I'm guessing that I posted this in the wrong place.

2-No one knows about Subaru B4 models even tho they are 21 years old.

3-everyone to busy in RL no time for forums.

4-all of the above 😂

Link to comment
Share on other sites

A couple of questions - did you fit a genuine Subaru thermostat or a generic, and did you burp the cooling system afterwards properly? 

On the matter of "no help" - best to have patience and consideration for all of us, some of whom may have far more pressing life problems going on than to jump to reply to you?

Link to comment
Share on other sites

6 hours ago, Greenmamba said:

A couple of questions - did you fit a genuine Subaru thermostat or a generic, and did you burp the cooling system afterwards properly? 

On the matter of "no help" - best to have patience and consideration for all of us, some of whom may have far more pressing life problems going on than to jump to reply to you?

serious mate you sound like my wife, I ask a question and get a question back 😂

I'm the one asking the questions here.

Are there 2 cooling sensors on this car, if yes where is its location?

either yes or no.

we all have problems in life.

this forum should be for car problems, not for people's personal lives.

I found out already how many sensors there are now.

It has been over 24 hours and I  get questions instead of an answer

great help

Link to comment
Share on other sites

13 hours ago, Greenmamba said:

Good luck on this forum if that is how you react when someone asks relevant questions. If you don't realise my questions are relevant to your problem you are too stupid to own a Subaru. End of conversation.

what help do you call that? I'm a mechanic bro don't you think I know about bleeding the system?

I ask questions and get questions as the answers, it would be more useful if you gave me the link to the workshop manual.

at least they have you to ask useless questions 🙂

I don't need luck mate already fixed my problem, if you are the only one here then good luck to all newcomers.🤣

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership