Jump to content

Firewall Grommets for power cable


Recommended Posts

Hey guys

 

I decided to buy a subwoofer/amp combo off ebay (bargain vibe 12" slick at £30!) as I felt the speakers were a bit flat... sound OK since I've put a better head unit in but not enough bass for my liking!

 

Anyway, onto the point of the thread... basically I'm confident in wiring it all up, looks like it will be easy to hide the wires etc... the only issue I have is running the power cable through the firewall to get to the Battery. Now I have just spent the best part of an hour in my car, drivers and passenger side trying to fin a suitable place to run this cable but with no joy!! I can't find a single grommet on the drivers side.

 

Passenger side seemed more promising... I stuffed my hand behind the glove box and found the main wiring bundle and a big grommet. So I removed the glove box easy enough only to encounter loads of other plastic looking stuff in the way which I opted not to touch! Looked inside the engine bay and found where the main wiring bundle comes out but I could not for the life of me remove the grommet! I think the wiring bundle is pretty taut so that could be why.

 

Does anyone know if this is the best place to route the cable through? I imagine so as that is the side the Battery is on... Any help/advice would be greatly appreciated!!

Link to comment
Share on other sites


Look from the engine bay there is a hole/grommet you can use by the brake servo, I used this on my classic for a few gauges, it comes out by the pedals.

 

 

hydramistpowercable2.JPG

 

On my New Age I used the main cable you are talking about, it is possible to use but you'll have to make a hole in the rubber and reseal it with some goo. I used bicycle puncture repair kit. I pushed a piece of thick gauge wire through and then attached the wires I wanted to feed through and pulled it into the engine bay that way.

Link to comment
Share on other sites

Thanks for the reply Scooby Pete!!

 

I've had another look and I can see two grommets to the right (I'm standing at the front of the car looking in) of the brake servo. Only issue is I have no idea where that leads to in the drivers foot well, like I said I've looked in the drivers foot well and seen nothing, seems to have a layer of insulation before the metal so dunno if that's possibly hiding the hole. Would it be a good idea to remove the grommet from the engine bay and may put a coathanger through and see if/where it comes out of the footwell? This is something I've never done before :D

Link to comment
Share on other sites

Thanks for the reply Scooby Pete!!

 

. Would it be a good idea to remove the grommet from the engine bay and may put a coathanger through and see if/where it comes out of the footwell? This is something I've never done before :D

 

 

Spot on that's exactly what I did, then if you want to use the hole you can gaffa tape the cable to the coat hanger and pull it back through.

 

I think they come through above the level of the pedals, may have to fold the carpet down to get to it, cant remember it was so long ago :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...




Forums


News


Membership