Jump to content

subaru legacy gtb


berny
 Share

Recommended Posts

help any idea,s just got back after max 2 miles its lost most ? of its oil no oil in water seems to be on passenger side cant see any oil near heads ,could it be sump gasket was running sweet at that time cheers any imput would be good

Link to comment
Share on other sites


help any idea,s just got back after max 2 miles its lost most ? of its oil no oil in water seems to be on passenger side cant see any oil near heads ,could it be sump gasket was running sweet at that time cheers any imput would be good

bump

Link to comment
Share on other sites

Do you have the plastic undertray on beneath the engine ? If the sump had lost it's oil chances are it will be all over that, another thing is to check the filter's on properly and it hasn't been punctured.

  • Like 1
Link to comment
Share on other sites

Have a good look under the rear of the engine. You are looking to see if the gearbox is wet with oil and probably the underside of the floor too.

If it is, it's probably the rear crank seal. If the areas above are not wet, look inside the under tray. If that's wet and oily, it can be a few things, sump gasket snd sump plug are less likely than front crank seal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership