Jump to content

Heating panel blanked


Fkend
 Share

Recommended Posts

XV 2013 Auto.

This morning after first cold night -5c.

engine stated no problems but heating controls not working. The heating info panel is blanked out, front and rear demister switches not working and heater and blower control not working.

I presume there must be a frozen relay somewhere, any suggestions which one and where is it and of course I may be totally wrong?

Just checked again outside temp now 6c and all started working again?

adrian

Edited by Fkend
Further information
Link to comment
Share on other sites


Sounds like a computer glitch, perhaps sorted after you turned the system  off then on again!

It may show up if connected to an obd 2 scanner. do you get a dealer service, as it would show up as a logged incident on their scanner..

Last thing you need on a cold morning...

Chris

Link to comment
Share on other sites

Cuvva - A better way to insure your car

Pay monthly without the interest. 0% APR. No deposit, no hidden fees.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership