Jump to content

Engine Management Light


GavLadLeeds
 Share

Recommended Posts

Engine management light has come on. I own a WRX 2006 decat exhaust. I have owned it for a week and I am devastated! I took it for a drive after work tonight, let it warm up so oil temp was good, tyres were warm and I drove it hard through gear 1, 2 and 3 then the car slumped and the light came on at 90mph. I pulled over straight away. The car seems to still drive ok but obviously there has been some sort of issue. I am getting the code read today. Fingers crossed it is something and nothing but I am worried! Any ideas?

Link to comment
Share on other sites


You paying for the code to be read mate ? I've a code reader you can borrow if you have an android phone ?

Could be something simple like a sensor tripping the car into safe mode. Without the diagnostic I wouldn't like to say though

  • Like 1
Link to comment
Share on other sites

My friend also has a code reader which he says he can do for me today. Thanks for the offer though. I was tempted just to take it straight to Richard Henry Motorsport in Bradford and see what they say but could be expensive just for code check!

Link to comment
Share on other sites

Just got back from RH Motorsport. They have said it is an overboost code on the history. They will clean out some pipes and a solanoid box on Thursday to hopefully cure it for me. Glad it isn't something major at this stage! What you guys think?

Link to comment
Share on other sites

I don't know for definate if it has been remapped - I don't think it has. Just a decat and a different air filter element in the standard air box to the best of my knowledge. I hope this cures it. For what i paid for the car i want it to be right! I love scoobys but something like this will annoy me if it keeps coming back to haunt me. Let's see on Thursday!

Link to comment
Share on other sites

If it's had the airfilter and decat and no remap thas maybe why it's spiking. Could be the wastegate acutator thats sticking too.

Fingers crossed it's an easy fix.

Have you a boost gauge fitted ? Easy way to monitor whats happening

Link to comment
Share on other sites

As Stants said really. Chances are it might not have been remapped or someone has played around with the actuator then claiming it to be mapped. I know a guy near me who does that it's ok I don't speak with him or have anything to do with people like that :) 

Link to comment
Share on other sites

No boost gauge fitted....yet! Sounds like it might need a remap. I have just been on the motorway and the power delivery in 5th gear at 3000rpm was really up and down! Not smooth at all when putting the foot down. I always said I wouldn't touch a turbo engine after my golf gt tdi for wastegate issues. I really hope that isn't the problem here!!!

Link to comment
Share on other sites

Just got the car back. The specialist says the car needs a remap and should have had one when the decat was put on and the different filter element. They couldn't believe it hadn't been remapped because no engine management lights were on! I called the guy i bought it off and he says "i never drove it hard so had no issues without a remap"!! I smell bulls**t ! Then he went on to tell me all about different remaps he looked at and how much they cost! Richard Henry Motorsport have said there guy can remap it for me for £300 which I think is an great price and I trust them. What you guys think / recommend?

Link to comment
Share on other sites

Sounds good and cheap mate, is that on a rolling road or live map ?

If you want comparative prices speak to simon @ jolly green monster or duncan @ race dynamix,

As gambit said it would have needed a resistor or map to remove the light coming on with no cat.

Link to comment
Share on other sites

Yeah that's what I though. Must be a resistor because he put the decat on and is certain it hasn't been mapped. RH Motorsport still don't believe that due to the power it is putting out in 1st and 2nd! Anyway - the guy who can map it is called Andrew Carr and from web research he comed with a great reputation! I think it is without rolling road.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...




Forums


News


Membership