Jump to content

New Member


Jord
 Share

Recommended Posts

Hi all,

I have just purchased my first Subaru Impreza WRX STi type UK and have a few questions as to the engine tick over. It seems to be slightly lumpy on idle/tick over almost as though there could be a slight misfire ... Not sure if this is normal. I've filled the car with V power.

Any feedback would be great as the car is under 3 months warranty just in case it needs to be sent back!!

P.S. Does anyone recommend any Subaru specialists in the Manchester area which I could potentially use for a diagnostics test.

Kind regards,

Jord

Link to comment
Share on other sites

Wotcha and welcome Jord - yes lumpy tickover is part of the Scooby charm due to unequal headers

 

feel free to get stuck in with the forum and dont be camera shy ;)

Link to comment
Share on other sites


Thanks for the comments guys! Still thinking of taking the car in for a diagnostics just to be sure everything is ok! I was looking at prosport as it isn't too far from me. 

Link to comment
Share on other sites

Hi and welcome :D

 

I always found that a lumpy tick over is a subaru's way of saying service me

 

you normaly find that when its ready the revs drop to about 400 and its lumpy give it a service and should be sweet again 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership