Jump to content

My blobeye hates petrol stations


jay14
 Share

Recommended Posts

Hi folks, have my Impreza just over 3 months now and starts no problem anwhere except garages the odd time. I pull in, fill up, lock the car (1 button key fob) to go in to pay, come out and

Unlock the car then try n start it and nothing happens, I have to keep locking and unlocking quite a few times again to get it to start! It been happening more often the last 2 weeks, I'm baffled, maybe its a shear coincidence it occurs at petrol stations but im scared to go near then now! Lol

Anyone came across this problem?

Link to comment
Share on other sites

Is it the standard factory alarm ?

Is it the same petrol station or random ones, could be that there's a lot of interference from radio comms or other magnetic interference as the sigma alarms in the other models are well known for it, some people have had to push the car a couple hundred meters away before it will start

Sent from my SM-G850F using Tapatalk

Link to comment
Share on other sites

LOL never heard of that one !!

I have a blobeye and mine loved the petrol stations cus I have to keep going lol

 

Have you tried not locking it etc see if that works?

I would try random things like a diferent station, different pump, etc

 

See if that helps?

Link to comment
Share on other sites

Yea it standard, I read about interference etc, seems something like that, is this a boob by Subaru? is there any fix for this? Is it a big job to change the factory immobiliser to an aftermarket?

Link to comment
Share on other sites

What temp is the car generally at when this happens?

Have you ever had this happen after going for a drive, doing the same procedure except for the filling with petrol part? I.e. Turn it off, lock, give it a minute, unlock and try starting?

Link to comment
Share on other sites

Its happened at 5 different stations, one time I wasn't even in for petrol but was parked a few meters away from pumps. Then sometimes it starts no problem, f*****g gremlins!! Lol

Link to comment
Share on other sites

What a ball ache !

Easy enough to get the old one ripped out and a decent aftermarket one put in but will set you back a few pennies, have you tried using the keypad to bypass the fob ?

Yeah the sigma ones are poo !

Sent from my SM-G850F using Tapatalk

Link to comment
Share on other sites

LOL shoot the gremlins!

 

If its just the immobiliser change shouldnt be to much depending on CAT1 or CAT2

 

CAT2 prob between £35-£50 not sure about a CAT1 though

Link to comment
Share on other sites

What temp is the car generally at when this happens?

Have you ever had this happen after going for a drive, doing the same procedure except for the filling with petrol part? I.e. Turn it off, lock, give it a minute, unlock and try starting?

its done it when cold and warm as I stopped at the station about half a mile from my house on way to work one morning without getting petrol but didn't lock it, came back, put key in, pressed the button and it wouldn't start, so removed key, locked then unlocked car again, key in and still not start, had to do this procedure about 4 or 5 times until it starts! I get sum looks at the forecourt lol. This is a real pain, then at home or car park at work I can start, stop, lock, start many times with no problems so it cant be the starter which I thought it mite be :S
Link to comment
Share on other sites

Sounds a bit daft but have you tried it with a spare fob or replacement battery in it ?

Sent from my SM-G850F using Tapatalk

Lol I know, never came across this before an I've had few jap imports before with different alarm/immobilizers without any problems.

I only have one key fob,

That's the next thing I'm gonna try is changing the Battery in the fob, anyone know off hand what type of Battery it takes?

Link to comment
Share on other sites

it's more common that people realise, it's to do with RF interference from the automatic door openers, some also use mobile phone signal blockers to stop people using their phones in the petrol station.

 

some people get it in supermarket car parks (near the doors), but most people don't/can't park close enough for the interference to be an issue

Link to comment
Share on other sites

its the imobilizer not disarming,check Battery in the fob,it could be worse 1 off my old cars imobelizer use to turn on at any time it liked,it did it once on a busy saturday afternoon half way round Mc donalds drive threw lol

Link to comment
Share on other sites

aucky, if it's just the immobiliser not disarming, how come it mainly happens in petrol stations?????

Don't know why, but will change Battery just to rule it out, it needs changed anyway, only works when standing beside the car
Link to comment
Share on other sites

  • 3 weeks later...

Just an update on this problem which I have now solved :)

I replaced Battery in key fob and drove and stoped at a few places with no problem, so thought I had solved it until I parked up at car park and when I went to start it wouldn't start again! I was parked on hill so thought id try and start it on a roll to see if it would start and it did!! So this tells me its a starter problem and couldn't be the immobilizer.

When I got home I switched the car off, popped the bonnet n had a look around the starter and noticed the single wire connection (signal wire I think) going to the top of the starter looked a bit grubby but before I touched it I thought id she if it would start 1st, and it didn't! So got some contact cleaner and disconnected the wire and cleaned it up the reconnected it and hey presto its starts! Have had no problems now for a few days since so fingers crossed that was all it was

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership