Jump to content

Alarm problem, help required


Recommended Posts

I have a 2001 Forester S turbo with what I believe to be a SIgma S30 alarm.  Up until yesterday everything was fine with the alarm system.  The car has been in for a replacement clutch today and now there is a problem with the alarm.  Apparently the Battery was disconnected for some time and now when I lock the car with the remote, the indicators flash, the alarm beeps for 15 seconds and then goes off.  The garage said I had to reprogram the remote but surely it is still programmed as it locks and unlocks the car?  Anyway, I tried using the PIN code on the keypad in the glove box and *91 to reprogram the remote, but it is still doing the same thing.

Can anyone offer me any help on this?

Link to comment
Share on other sites


Brilliant! Thank you very much.

I looked under the bonnet and the switch has no wires coming from it, so they have obviously forgotten to reconnect it.   I have tried looking for any loose wires attached to a connector but without success.  Where should I look?   

 I just found that the wire come in from the rear of the switch, and in fact the switch had been bent down a little as you suggested.  Now I have bent it back, everything is fine.  Once again, thanks.



Edited by SteveP
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...