Jump to content

Smoke from vents??


Guest
 Share

Recommended Posts

Hi all,

Today on my way home from work I noticed some wisps of a white 'smoke' coming from the vents. It only lasted a short time (I immediately thought it was the A/C as it was re-gassed the other day) so I turned the A/C off and pulled over and let the car idle.

The car did not raise in temperature and gave absolutely no signs of having an issue.

A few things to note:
- I had the spark plugs/ gearbox oil and brake fluid changed yesterday
- I had the A/C re-gassed a few days ago as it's never worked since I've owned the car

Has anyone has this before... any ideas?

My thoughts are either:
- Condensation from the A/C (but weird it was only one wisp?)
- Some oil dripped from the gearbox onto the exhaust (but why would it come through the vents?)

Help will be appreciated!

 

Thanks
Matt

(2010 WRX-S)

Link to comment
Share on other sites


My van used to do it.does it steam the windiws up if you have it on windscreen if so feel the vapour if its slimy its a blown heater matrix 

Link to comment
Share on other sites

Holts rad weld double dosed fixed mine lol 

I am in no way tellin u it is that and please dont copy me lol my van was only worth 2k so i dint care if it fked it up lol luckily it didnt like

Link to comment
Share on other sites

8 minutes ago, Rps said:

Holts rad weld double dosed fixed mine lol 

I am in no way tellin u it is that and please dont copy me lol my van was only worth 2k so i dint care if it fked it up lol luckily it didnt like

Fortunately the windows never mist up, so i think thats all good! I'll save the rad weld... for now! :laugh:

Link to comment
Share on other sites

9 minutes ago, Linx said:

I see mist coming in when the aircon is on not smoke. That's normal.

 

Sent from my HTC Desire 530 using Tapatalk

 

 

The only thing is... a few seconds before I did smell something 'dodgy' that smelt almost like burnt clutch (only way I can describe it).

Again this could be related to the aircon pushing out the condensation?

Link to comment
Share on other sites

Ah. If the drive belt slips when the aircon is on it can make a burning rubber smell.

 

Sent from my HTC Desire 530 using Tapatalk

 

 

Link to comment
Share on other sites

Ah ok, well if its a slipping belt I won't be too worried... if it's coolant or gasses leaking into the vents maybe I will concerned as i'm sure thats not good to breath in! 

Link to comment
Share on other sites

2 minutes ago, Rps said:

Put all windows up n see if u die.

if not u no ul be ok haha

Best advise I've had all day :laugh: 

If i'm not active again.. ever you know what the problem was!

Link to comment
Share on other sites

Ok so now another problems surfaced in the same area... 

Since the 'smoke'/ condensation whatever it was I hadn't turned the air conditioning back on until today and when I did... nothing happened, there was no 'click' of the relay, the engine revs didn't change slightly, absolutely nothing. More importantly the air temp did not change. 

If I turn the climate system completely off, then the revs drop and back on they pick up again slightly - so I don't know if the A/C is jammed on, or off! But either way it's not changing between one or the other.

Any ideas? Could this be related? 

Thanks!
Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...




Forums


News


Membership