Jump to content

Soctty

Members
  • Posts

    3
  • Joined

  • Last visited

Profile Information

  • Location:
    Warwickshire
  • Subaru Model
    Impreza 94

Soctty's Achievements

Member

Member (1/14)

  • First Post
  • Conversation Starter
  • Week One Done
  • One Month Later
  • One Year In

Recent Badges

0

Reputation

  1. Cheers mattb Hi sandals, this is my next step for vacuum leaks planning to test it all today god help me lol
  2. Hi Scooby wizards Right guys serious help needed might take a while but will start from the beginning. First off heads went on my motor after heater matrix let go as well. I had stripped the whole dash out to fit upgraded heater matrix, I had a spare engine which I had stripped and rebuilt completely as it had sat for about 4 years. Cleaned the engine bay and sprayed the bay. Refitted the new engine connected everything up started it and on choke it runs fine as soon as it’s off it’s hunting and rough idling. Dash came up with code 24 which is idle control valve and temperature sensor code. Decided to swap idle control valve from the old engine as I know it was working and nothing, along with after changing TPS as well, and still done exactly the same. I have removed wiring to get it tested by someone as electrics are a weak point for me tbh and if anybody knows anyone who is really good with wiring looms local to Warwick if possible could you put me in touch with them. Just wanted to know if anybody else had any other suggestions or ideas? Its a Subaru Impreza classic 94 ej20 thanks in advance peeps
×
×
  • Create New...




Forums


News


Membership