adarm

Members
  • Content Count

    20
  • Joined

  • Last visited

Community Reputation

0 Neutral

About adarm

  • Rank
    Member

Profile Information

  • Location:
    kent
  • Subaru Model
    wrx

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. That's really interesting post dude, thank you for that :) it's running 1.3bar at present... spoke to slowboy (neil) today, and he said it all looks fine, so just head gasket replacement, and a map I believe...so £1600 later, I will have my fixed car friday...oh great, it's raining for the next 6 months [emoji1787][emoji1690] Sent from my SM-G955F using Tapatalk
  2. Thanks bro...it was race dynamics, before the map I even asked if they could check internals to see if any damage had been done, not that I drive the car hard at all just to me on the safe side... appreicate your comments dude :) well it's being fixed at present so fingers crossed Sent from my SM-G955F using Tapatalk
  3. Helps if I put the right invoice upload Sent from my SM-G955F using Tapatalk
  4. Hey buddy, it was a fully forged engine, I got it with 12k on it, done about 8k, so engine only done 20k...why the fudge did it break...I have spent 10k in a year, ffs... the invoice below will show what's been put in it...and loads more... slowboy is gonna skim the heads, new gasket on it and put a forged air induction kit... at present its 345bhp...if I'm gonna spend 2k may as well make it faster I suppose [emoji85][emoji3166][emoji1690][emoji882] Sent from my SM-G955F using Tapatalk
  5. !Removed! E D Sent from my SM-G955F using Tapatalk
  6. Headgaskets:( has been found to be !Removed! :( Sent from my SM-G955F using Tapatalk
  7. Thank u my man...its going upto slowboy racing at Brandshatch today, he seems to he the man Sent from my SM-G955F using Tapatalk
  8. ***not again*** change rad etc, let it bleed with funnel etc....all went fine, got to temp, fans kicked in at 96 degrees etc, did that 4 times, air came out, nothing dumped in overflow tank happy days...then took it for a blast, didn't go above 90mph, gave it a little stick, took it to 6.5rpm then a light came on.... Cleared that...then nearly got to my destination (thrashed ot abit), car got to 96, fans kicked in, went down to 94, then went back upto 98, which I then turned it off... it had dumped all coolant into overlfow as it has done before... had to let the car cool, to put more coolant in the header tank...drive slow on way home , and no coolant dumped in overflow...headgaskets maybe?? Sent from my SM-G955F using Tapatalk
  9. Show them my pic will shut them up :) Sent from my SM-G955F using Tapatalk
  10. Thanks for your help buddy...I'm genuinely shocked Sent from my SM-G955F using Tapatalk
  11. For those who are interested...mother !Removed! mitsomoto...utter ****!!! Sent from my SM-G955F using Tapatalk
  12. First pic, the Alan key will not go any further, 2nd and third u can see it goes all the way in ( that's what she said [emoji1787][emoji1787][emoji1787]) Sent from my SM-G955F using Tapatalk
  13. Update....my new mitsomoto rad has a block on it at the top, partial block, ffs, at least I know now...thanks so much for everyone's help dudes :) will keep you updated when I get a new one #paininmyarse Sent from my SM-G955F using Tapatalk
  14. Hey mate...I changed the header tank to mitsomoto as a few people said that if dif pressure on rad cap and header tank cap it will dump all coolant into overflow...I have now changed the header tank and it's doing that same...do u think it could be a blocked rad, even though its new?? Thank buddy :( Sent from my SM-G955F using Tapatalk
  15. Checked hoses, all hot and top hose still squishy :) Sent from my SM-G955F using Tapatalk