Jump to content

02 JDM instrument cluster question


Bahnstormer
 Share

Recommended Posts

Hi all,

Quick question for you - I've noticed that there is no side/headlight warning lamp on the instrument cluster of my 02 WRX, is this right?  All the cars I've ever owned have had a little green light to tell you the side/headlights are on.  It's not a big issue as I can simply look at the stalk if I want to check, but I thought I'd ask before taking the cluster out to check for a bad bulb.

I've noticed there seems to be a few variations on the instrument clusters, mine has the speedo on the far right with the rev counter in the middle.

 

 

 

Link to comment
Share on other sites


I've been told my 52 plate UK sti has had a jdm clock swap , did wonder if there was supposed  to be a "sidelight on " light . 

Dont know if yours are the same clocks as mine ?

In mine when the side lights are on,  the clocks ,switches and gauges illuminate .The digital outside temp odometer LCD screens dim a bit as well .

I have left them on a few times but thankfully ,they shut off when the keys aren't in the ignition .

Screenshot_20190407-114337_Samsung Internet.jpg

  • Like 1
Link to comment
Share on other sites

I wouldn't take it as gospel , I'm not up to spec on newage,  I've never seen one on my dash and so try to use the change in back lights as a reference when driving,  instead of looking down at the stalk position 

I do tend to use the side lights more , as loads of newer cars have daytime running lights and you do tend to notice them .

 

Link to comment
Share on other sites

Well, went for a drive this evening and noticed that my external temp display doesn't light up :laugh:, so looks like I'll be taking the cluster out after all.  Luckily I've accumulated plenty of dash bulbs over the years so that should be any easy enough fix.  While it's out I'll see if I can see anything about the sidelights on the cluster 👍.

Link to comment
Share on other sites

Just in case anyone else ever wonders this, there is no sidelight warning lamp on the dash cluster.  I had the cluster out to replace a blown temp display bulb and while I was at it, I split the cluster and checked the black backing for signs of a warning light, but it doesn't have one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...




Forums


News


Membership