Jump to content

Engine light


MJP02
 Share

Recommended Posts

Hey all

I have an 02 bug wrx, recently I've noticed when I've accelerated hard at high speeds my engine light flashes, the first few times it stopped when I slowed but yesterday it stayed on. I have got a reader so I plugged it in and it says misfire on 1 & 2 cylinders. It didn't feel like it was missing. I have got new plugs on order but is this a common thing? should I look at getting new coil packs to?

 

Thanks for the advice

Link to comment
Share on other sites


I ordered standard plugs so far  NGK 3500 PFR6B - Double Platinum Spark Plugs

Not long had the car, apart from a back box i think its totally standard, also ordered the cosworth filter and walbro fuel pump, serviced it with millers 10 60, new disc's and pads all round and new front callipers plus new eagle f1's all round

Link to comment
Share on other sites

Ok swapped the plugs at the weekend, old ones looked in really good condition. 

So today was first time to test and now i can feel the car almost pulling back when at high speed.

Should i get new standard coil packs or uprated ones.

Like these http://www.ebay.co.uk/itm/121897371978?_trksid=p2060353.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT

 

 

Link to comment
Share on other sites

Cuvva - A better way to insure your car

Pay monthly without the interest. 0% APR. No deposit, no hidden fees.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership