Jump to content

Subaru Starlink Infotainment System


Denise Neville
 Share

Recommended Posts

We own a Subaru XV, 2017, which until recently had a perfectly functioning Starlink Infotainment System.  Then out of the blue, it decided not to boot up.  It is constantly going through the motions of starting, getting so far, then failing.  It turns off, then turns on again and goes through the same procedure.  This was particularly annoying last night on a trip up north in the dark, very distracting.  So far, we have gone back to the garage where we purchased it from, they showed very little interest and said they would call back, which they didnt.  Another garage informed us that they did not have the capabilities to do the job and referred us to another Subaru Garage.  They had the car for a considerable time, and reported back that it would mean a new unit.  We have browsed the internet to try and see if there is a similar story, but cannot find it.  Any help would be greatly appreciated.  I attach a screen shot of the video I took earlier.

241933558_194001376156061_7346582067582078935_n.jpg

Link to comment
Share on other sites

Unless the unit is defective the most likely problem is that the internal firmware/software is corrupted so that the boot up process is being stalled. The XV I owned was a later model but if it were mine I’d locate the radio fuse and take it out for a while and hope this might clear any internal data. Try a reboot. If that did not clear the issue then download the latest firmware/software onto a USB and see if I could get the unit to reinstall the operating system. (Or SD card not sure how your unit works but the Subaru support page should help you with that)

Not much help I’m afraid but it does look essentially like a boot up problem. Sadly most garages in my experience have no knowledge or interest in sorting Head Unit problems. There are specialist companies who sell units and a call to them or a visit might be beneficial.

Hope you get it sorted.

  • Like 1
Link to comment
Share on other sites


4 hours ago, Denise Neville said:

Thank you ernieb.  Just as I had feared.  I was interested to find that there has been a lawsuit against Subaru in the US for faulty Starlink systems.  I have dropped a line to Subaru, as 4 years for a system to work and then fail, isnt satisfactory at all.

 

Totally agree with you and part of the problem is that these items are badged from other manufactures, e.g. Harman, so the real expertise and possible liability is with a third party. Your claim, however, is with Subaru UK. Good luck and hope you have some success but these things are always trying and potentially long winded.

Link to comment
Share on other sites

  • 4 months later...

Sorry to read about your problem.  I have a 2015 Outback that has just decided not to load the "Starlink"Navigation system, after the Battery went flat I have tried the usual tricks remove the SD Card and replace, disconnect the Battery and reconnect. Neither worked. I found a Site on RubaruOutback.org for "firmware" update, but when registering my vehicle, it did not recognise it's VIN number.  I assume that it  is USA only.  I am now almost at end of options, I have a SD Card the directory of which can be read on a computer, but cannot be accessed and a Navigation system which will not work, the rest of the Starlink system appears to be working.

Hope you have better luck, I had an Impreza 2000 turbo for 18 years and an Estate for 8 years, trouble free.  Now I also have an 2018 Impreza 2000, which has already had 2 recalls and failed an MOT.  Times seem to have changed.

Link to comment
Share on other sites

Cuvva - A better way to insure your car

Pay monthly without the interest. 0% APR. No deposit, no hidden fees.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership