Jump to content

HELP!! 2005 blobeye wrx sti not running


Linzi
 Share

Recommended Posts

Hello everyone, just here for Abit of advise.. My car keeps cutting out and stalling.. it was perfectly fine the other day. I came to start it this morning and it wouldn’t start.. I jumped it thinking the Battery had gone abit flat.. anyway to cut a long story short.. its now struggling to start and then cuts out . The car stinks of fuel when trying to turn it over and it shakes like mad then misfires when it it’s being revved.. has anyone come across this before? It’s that bad I can’t drive it! TIA I do have a vid but it won’t upload onto here!

Link to comment
Share on other sites


First place to start would be to get the ECU codes read , hopefully this will point you in the right direction of what's wrong .

Most garages will have a subaru odb2 compatible code reader . Or you could either buy a cheap reader or a OBD 2 Bluetooth adapter and use the torque app on a smart phone .

Link to comment
Share on other sites

Wotcha and welcome - as above could be a number of things so if you can get some codes that will help

this is what I use

https://www.ebay.co.uk/itm/ELM327-ODB-ODB2-V2-1-Advanced-Bluetooth-Car-Auto-Diagnostic-Scanner-Tool-Ku/223293585680?hash=item33fd55b910:g:LgYAAOSwkNFcXFYz

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...




Forums


News


Membership