Jump to content

Backfiring Forrester 2.0T


alfanige
 Share

Recommended Posts

Hi guys

 

I have a 2000 2.0T Forrester which started off as having a hesitation if you put your foot down sharply. Soo.... I spent the day doing..

 

1. Stripped off the top mount i/c

2. Stripped apart the throttle body and cleaned it thoroughly

3. The coil pack was also whipped off and cleaned and the terminals checked.

4. Also took the front Lambda sensor out*

 

OK, these are the notes from the above work

 

A: The IACV looks to have a cracked the inner part (inside the spring) as the actual plunger can be twisted round and pulled in and out.

B: The lamda sensor appears to be a Bosch 0 258 986 502, which I believe is a "generic" sensor. It looks like it was cross threaded when fitted as well. It was an !Removed! to undo as well!

C: a small pin hole was found in the vacuum hose from the intake to the "T" piece with the short section then off to the wastegate, so was replaced

D: The wastegate although very corroded seemed to be moving freely.

 

Now, put it all back together and hey presto, the car idles beautifully at 750rpm (it fluctuated a bit before). But, when blipping the throttle it now backfires. If you smoothly operate the throttle it doesn't.

 

What I have noticed though is that whatever I do under the bonnet, the wastegate doesn't seem to move at all.

 

I have a generic diagnostic tool, which I use on most cars, but this is giving me no help and says there are no error codes, although I know that isn't right as the EML has been on and I can force it on by unplugging something for example - so in other words, I have no diagnostic.

 

Last thing I have tried is disconnecting the Lambda sensor - it make no difference at all to anything.

 

My suspicions are

i. Front Lambda Sensor needs replacing with a correct one

ii, Coil pack is giving up

iii, I should have spent the day in the pub instead

iv. The IACV is knackered (but why would that cause a backfire)

v. I should have worked on my old Alfa instead today

 

Anyone got any thoughts?

Link to comment
Share on other sites

Hi sorry I came on late last night and see this but was just getting ready to watch a movie. 

Option III sounds like it was the winner for me ;) 

Is it an automatic ?

I would try look at Throttle position sensor causes hesitation on acceleration. If you not getting an ECU light, look for vacuum leak around the air flow duct to the throttle body. And check it's all tight but look at what you have put I'm sure you have checked that. 

Could be bad coil packs or fuel pressure/pump 

Link to comment
Share on other sites

Cheers chap, I am still at it lol! I am going to bench test the lambda and run a test on the coil pack. I have, I believe, checked all round for a vacuum leak as I am pretty sure it must be an air/fuel ration proble if its backfiring

 

I have tried running the car with the lambda disconnected, the TPS disconnected and the IACV disconnect (not all at the same time!) and it doesnt seem to make any difference. Its !Removed! annoying as the car only had a hesitation before I started and now it has this !Removed! great misfire and no power! Is the pub open yet........

 

Its a manual by the way

Link to comment
Share on other sites

Backfire is usually caused my excess fuel or iffy spark, if there's a dump valve these can cause a small pop, as the boost is released the ecu isn't mapped to know it's going to release so keeps fueling for a split second causing the extra fuel to to into the exhaust and hit a hot turbo causing a pop

A knackered coil pack can also be to blame

As for no eml, this only comes on for something controlled electrically by the ecu, as the turbo and it's components are not controlled by it then it doesn't know to tell you there's a problem

If the actuator is not moving under acceleration this will stop the car reaching its required boost level and is probably caused by an air leak, a tiny hole or crack anywhere in the system could cause this

Have you checked over all the pipes you removed, I messed about with the intercooler a while back on mine, I took it in the house to straighten all the bent fins, when I put it back I left off the pipe from the dump valve, the car sounded odd and didn't boost right, I assumed I'd punctured the i/c until I spotted the pipe

Can you hear any hissing from under the bonnet on idle, although mine idled lumpy but you could have a pin hole somewhere

Link to comment
Share on other sites

Coil pack seems to be working OK, but the lambda sensor is only reading up to 0.4v at most, which is a bit low I believe. I think this has been the trouble all along - the hesitation etc to start with. 

 

My theory is thus...

The ECU had been adjusting to the dirty throttle body and compensating for the drop in vacuum from the perforated hose whilst the lambda was working. As the lambda started to deteriorate it ceased to operate as effectively bringing with it heavier fuel use and hesitation under load.

 

Now that I have had everything apart, cleaned it all up, replaced the vacuum hoses that were perforated I think the ECU is unable to re-adjust the fueling to try and achieve lambda and its so far out from the previous settings that its causing the backfire OR is taking the reading from the lambda as it is and thats simply the cause of it.

/theory!

 

I have disconnected the Battery for a wee while (OK 20 mins was as long as I could wait!) in the hope it would reset the ECU memory settings and bring the base reading for lambda back to like a factory default as I cant work out or find out if the lamda circuit starts from a fresh every time the ignition is cycled. Anyway, that didn't make a bit of difference!

 

Sooo....I shall get a new lambda sensor and also hopefully by Tuesday I will have the Subaru diagnostic tool in my hands, which may help me somewhat!

 

Last question...the lambda fitted is Bosch 0 258 986 502, which I believe is a generic one, any advice on this and if so what should it be

Cheers

AN

Link to comment
Share on other sites

Cheers Miggs, your reply came in as I was a typin'

 

I belive all the vacuum hoses are in the right place and connected, I ve had it apart about 10 times now :-D. I did the same with the i/c and straightened all the fins out - I ground down an old steak knife to a thin blade, just wide enough to go through the fins, did the job a treat....well I presume it did, the car hasnt run since :-D

  • Like 1
Link to comment
Share on other sites

I know what it's like. You know there is a problem but with no ECU codes getting to the bottom is a real pain in the !Removed! :( 

I've had many times seeing how far I can launch some sort of tool across the garage or yard and have a few minutes to walk and pick it back up again ;) 

And it does seem to by what you are saying could be a dying Lambda sensor on it's way out.As for the right one I'm not sure if it's right Tlag is best person I know who might be able to answer that for you or his Son Bip if he comes on.  

 

What year is the  the Fozzer ? I'm guessing it's after 2001 ?

Link to comment
Share on other sites

I'm not sure how accurate this is but I was always told to leave the Battery off for an hour, it's always been left overnight or an hour 10 mins and worked for me, also with vw's if you undo the terminals of the Battery and touch together for 10 seconds OFF Battery it drains the residual power from the system, not sure if that works with subarus

Link to comment
Share on other sites

Cheers for the help guys. I agree about the lambda, same as the MAF, no point in a cheap one or refurb one which is why I asked the question. Although the one in it is a Bosch one, its a generic one which I am not keen on replacing with the same.

 

As for the ECU reset, most cars are indeed an hour or so with the Battery off unless you are reflashing it but usually refers to Bosch ECU equipped cars. I thought it a shorter period on others. Is it a Denso on the Forester, I haven't even looked lol! The touching of the terminals together I thing is a bit of a "poisson rouge" in my opinion, but hey, who knows :-D

 

I have indeed gone and collected the tools from around the barn and workshop after a wee tantrum this afternoon. It was a nicely launched 22mm spanner that slipped off the lambda sensor throwing my knuckles into the bulkead :-D

 

Its a V plate, year 2000 or 2001 I think.

 

Off for many beers and a curry in order to forget all about the damn thing now :-D

Link to comment
Share on other sites

If that spec fuzzy is the same as the impreza it should be obd2 also if by generic you mean original equipment then it could well have been in for some years already and thus why it's failing, if you mean generic for its fault then that's not something I know about for that particular part, any cars I've had lambdas on has always been juicy and decatted so a failing sensor wouldn't be noticeable unless I got the problems you described, my current lambda is faulty and causes a slight over fueling but that's all, I had a v6 golf with twin cats and 4 lambdas, 2 of them failed but at 130 notes each I just lived with the over fueling instead, it helps having a tester at the mot station that looks the other way for non safety related issues

Link to comment
Share on other sites

I was referring to the lambda part currently installed - its a generic Bosch one, not an OEM or OE Spec part - and I was looking to install the correct one specific for the car.

 

The car is OBD2, Subaru code reader already ordered :-)

 

Anyhow, its raining hard here and I will get wet walking over to the barn, therefore the sofa wins!

  • Like 1
Link to comment
Share on other sites

Well guys, the new Lambda is installed and the car is running again, no backfire. The Lambda is now reading up to 0.9v which it wasn't before.

 

I do still have some flat spots when accelerating though which may smooth out once the adjustments have completed, around 50-100 miles I presume. I will whip out the plugs tomorrow and maybe swap out the throttle position sensor, but I feel I am getting somewhere.

 

The diagnostic tool I bought doesn't work at all though! The car was registered on 03/11/99 and is of course OBD2, but the tool just aint working which is a bugger. I chanced it with a £25 job off eBay, so my own fault really. Then again my usual scanner didnt work on this car either.....

Link to comment
Share on other sites

is there an indication light on the scanner tool to say if it's getting power? my obd cable has a blue light on to say it's receiving, as the power comes from the socket in the car and you've tried 2 tools on it and neither work i wonder if it's a problem with the socket

Link to comment
Share on other sites

Still got a lumpy power delivery :-(. Took two of the plugs out (WHAT AN !Removed!!!!) and found the gap at 07mm so widened them to .8mm which I believe is correct for this car. Will change them when I get the will to live again

 

Scanner tool still not working (there is power to it) and the !Removed! check engine light came back on just now. aaaaaggggghhhhhh

 

I think this car was designed with the American market in mind - as pay back for WW2! Only Alfa Romeo have come up with ways to make life harder

Link to comment
Share on other sites

Yahooo! 

 

Percy Verance gave me a hand and I have got to the bottom of it.

 

I tried an old laptop with XP on it and the scanner worked fine.

 

Up she popped, Code 22, Knock Sensor. Should have realised that before but as the Lambda was only getting to 0.3v it kinda side tracked me.

 

Will order one next week and fit it - i've had enough of this car this week and am going back to working on my Alfa - oh hang on, thats got a !Removed! flat four as well....aaaagggggghhhhhh :-D

 

Huge thanks to everyone here for the pointers and humour, I will be back!

Link to comment
Share on other sites

Whoop-whoop result and at least you have got it now. And should have thought about the knock sensor. Oh well I'm sure I will forget ready for the next person :D 

And just pop back when you like mate always something to take the Pi$$ out of ;) 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership