Jump to content

Hi Im Ethan


eth121
 Share

Recommended Posts

Wotcha and welcome Ethan!! we do love a pic on here but also feel free to get stuck in - friendly bunch and if you want any classic type inspiration have a look at some of the project threads

Link to comment
Share on other sites

Had a cam seize ( inlet right) which resulted in both left cam pulleys shattering. Luckily no damage to pistons/valves. New heads fitted along with all new gaskets, New pulleys, timing belt kit. But now I have an intermittent non start, she'll just crank over but won't fire. But I've found if I swap the two fuel pipes round, and try and start it. Then swap them back over again, she fires and runs fine.

Link to comment
Share on other sites

Hi Ethan,another fan of the classic,hope you get sorted soon :)

 

My 1st sub ,had mine around 6 months to and love it. Had a big 4x4  for years,so always wanted a nippy awd motor and so my journey begins :)

Link to comment
Share on other sites

The two fuel pipes That run from the fuel filter to the rails, it's weird because it might start four days in a row but then all of a sudden she'll just turn over and won't fire until I swap the pipes, try and start, then swap them back and she'll be fine.

Hi ven, same here . I've had landys previous to this

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership