Jump to content

Boost issues


Yorkshireviking
 Share

Recommended Posts

Hi new to the group and new to subarus

I have owned my 1997uk turbo for a week now and believe its not boosting right it shows 8/9psi it has a manual boost controll fitted and previous owner said he had turned it up by 2psi meaning stock boost is 7psi seems very low 

I have disconnected Battery to reset ecu and still having same boost the boost holds so no leaks 

Any ideas before i buy a new boost solinoid

Thanks in advance

Link to comment
Share on other sites

First port of call is to remove that boost controller. Stock boost is 0.9bar or 12.6psi. Id have a strange inkling that boost controller isn't doing anything at all. 8psi would be giving you actuated boost pressure.

Try to chase all boost pipes and reset everything to factory setting to rule out "modified" parts. If you're using a boost gauge it may also be worth checking the wiring for earthing issues or poor power supply.

  • Like 3
Link to comment
Share on other sites


Cuvva - A better way to insure your car

Pay monthly without the interest. 0% APR. No deposit, no hidden fees.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership