Jump to content

Vvt help needed


Piggysniffer
 Share

Recommended Posts

Hi all, I have issues with my avcs/vvt on my hawk wrx, I've logged the vvt for left and right and it looks like the issue is with the LEFT vvt 

can anyone tell me which side is considered to be the left vvt when logging with romraider please 

Link to comment
Share on other sites


Sorry I saw vvt in the title and didn't even read it , as I have no experience with scooby vvt ,cos classics don't have it 😉

But you mentioning that it might be a left bank cam issue has reminded me of a fairly common fault which sometimes affects bugeyes.

It's a earthing issue that gives a left bank cam sensor fault which is resolved by attaching a extra earth to either the engine loom or left hand head (can't remember if it was 1 or both you have to earth ).

So it might be worth putting a extra temporary earth on that side to see if it resolves the fault ?

If it's not broke .....upgrade it 😊

Link to comment
Share on other sites

Ok guys thanks, will have a little look into it savs, problem I'm having is with the actual cam gear I think, if I hold a steady throttle, eg:- 1600 rpm, the right bank will hold steady at 10 degrees of advance where as the left side will just search from 0 degrees up to about 22 then just keeps repeating that cycle all the way up and back down, gonna change the solenoids over to see if it changes sides, I've checked them for operation and they are fine outta the car but will try it anyway, the filters have been removed from the ocv banjo bolts too, so I think it's pointing at avcs cam wheel, this is where all my logged knock events have come from since I've had the car, cos with the avcs solenoids disconnected I have as close to no knock registered as you could hope to get

Link to comment
Share on other sites

Ok update time to help anyone else that may have the same problem, changed the oil control valves/solenoids for the avcs over from side to side and the problem of it searching up and down moved to the right side but not as bad as it was in the left, the left now held steady, so looks like oil control valve issue as well as cam gear or instead of, have had them both out and cleaned the bejeezus out of them and refitted , the big searching numbers and the searching up and down have mostly stopped, but the suspect left side (put the solenoids back to their original places) is laggy compared to the good side, so tomorrow I will change the solenoids over again to see if the lag follows the solenoid or if it stays put and then looks like a cam gear problem still 

  • Like 2
Link to comment
Share on other sites

Ok lads n ladies, hopefully final update, 

recieved one of the new ocv/solenoids today, fitted it in place of the one that was lagging during my romraider logging sessions, and it seems that the car is finally fixed after all these months, avcs and vvt are all working as they should, car is back to full power across the entire range and more so as it had just been mapped, now I have had some issues with timing randomly being pulled since i got the car and this got considerably worse a few hours after the mapping, I presume because my mapper used more avcs in the tune and this put more strain on an already failing solenoid, so as it stands at this moment the car is running properly, I will continue to log and put some miles on it and hopefully all will stay as is fingers crossed

  • Like 2
Link to comment
Share on other sites

19 hours ago, Piggysniffer said:

Ok lads n ladies, hopefully final update, 

recieved one of the new ocv/solenoids today, fitted it in place of the one that was lagging during my romraider logging sessions, and it seems that the car is finally fixed after all these months, avcs and vvt are all working as they should, car is back to full power across the entire range and more so as it had just been mapped, now I have had some issues with timing randomly being pulled since i got the car and this got considerably worse a few hours after the mapping, I presume because my mapper used more avcs in the tune and this put more strain on an already failing solenoid, so as it stands at this moment the car is running properly, I will continue to log and put some miles on it and hopefully all will stay as is fingers crossed

Problem may well be the map is wrong, a fault like that would have been present way before it was mapped. Mapper should have spotted it straight away and stopped mapping it.

Link to comment
Share on other sites

29 minutes ago, Piggysniffer said:

Thanks mate, ya can only help with the stuff you know I spose 🙂

This is true when it comes to ECU I'm limited. PC on the other hand no problem :laugh: I even fitted a fully working PC in my car that started and turned off with the ignition and had a touch screen monitor in the dash. I've since taken it out and going with a tablet now. mainly for the torque pro app thats about as far as my ECU reading ability goes :laugh:

  • Like 1
Link to comment
Share on other sites

Will keep an eye on things tidgy, as its not pulling any timing yet, but need to see if the fuel trims start going negative again, now I'm not one for blowing smoke up orifices if it's not warranted and we have chatted on pm about it, so if it goes south again it will be going back to mapper, but..... On the day it was mapped, I changed the oil to 10w60 and quite honestly (even said to the wife on the way up) the car drove faultlessly, so I can only imagine that for whatever reason on that day for that journey and mapping all worked well ? 

Im about as good with mapping as I am with bricklaying so I could really be piddling up the wrong tree thinking that, I suppose time will tell mate

Link to comment
Share on other sites

12 minutes ago, Piggysniffer said:

🙂 and therein lies my weakness.... computers, along with bricklaying, roofing etc etc 😛

I can't bricklay well not very well I have done it but I'm a plumber by trade so picked a few bits up among other things I seem to have taken up :laugh:

Well as I've said before if it has been mapped wrong they should in all honesty do it again and for free. I've heard a bit about what's gone on. but either way hope it's sorted :wink:

Link to comment
Share on other sites

I worked for a guy years ago when I was a nipper doing pcv Windows, conservatories etc, we had to build up the corner of a broken wall to do a little outhouse thing, built it up on the Friday, went back on the monday (isle of wight) to put the Windows etc on, wall hadn't set, we sorta got sacked from that job and I was put off sand and cement for life lol

Link to comment
Share on other sites

If it's mapped wrong it'll surely be redone for free, I can only be the shepherd up until the point I feel I'm being mugged off, then it'll all get a bit pulp fiction, marcelus wallaces briefcase, chill yolanda, Tim Rothish hahaha

Link to comment
Share on other sites

1 hour ago, Piggysniffer said:

Will keep an eye on things tidgy, as its not pulling any timing yet, but need to see if the fuel trims start going negative again, now I'm not one for blowing smoke up orifices if it's not warranted and we have chatted on pm about it, so if it goes south again it will be going back to mapper, but..... On the day it was mapped, I changed the oil to 10w60 and quite honestly (even said to the wife on the way up) the car drove faultlessly, so I can only imagine that for whatever reason on that day for that journey and mapping all worked well ? 

Im about as good with mapping as I am with bricklaying so I could really be piddling up the wrong tree thinking that, I suppose time will tell mate

just have to see how it goes mate

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...




Forums


News


Membership