ade

Intermittent Central Locking Problem

Recommended Posts

Hi all, I've spent a while searching through the forum looking for my particular problem and whilst I have found a nod to it I have yet to find any real detail so I'm hoping someone can help me.

I've had my 2012 XV for about 2.5 years and all has been well, but for the last month or so I keep getting an intermittent problem with the central locking.

It occurs whenever I finish a journey, I park, turn off the engine and 9 times out of 10 the central locking will unlock, however the rest of the time the locks don't unlock, I try the button nothing, I try the manual lock button - no change, I get the key fob out of my pocket and lock and unlock the car and after a couple of goes it works. I've changed the batteries in both key fobs to know effect.

I have found that sometimes even when I am driving if I press the unlock button it has no effect.

Before I book it into a dealers to have a look at has anyone come across a similar problem and been able to resolve it? 

Thanks in advance

Ade

Share this post


Link to post
Share on other sites
15 hours ago, ade said:

Hi all, I've spent a while searching through the forum looking for my particular problem and whilst I have found a nod to it I have yet to find any real detail so I'm hoping someone can help me.

I've had my 2012 XV for about 2.5 years and all has been well, but for the last month or so I keep getting an intermittent problem with the central locking.

It occurs whenever I finish a journey, I park, turn off the engine and 9 times out of 10 the central locking will unlock, however the rest of the time the locks don't unlock, I try the button nothing, I try the manual lock button - no change, I get the key fob out of my pocket and lock and unlock the car and after a couple of goes it works. I've changed the batteries in both key fobs to know effect.

I have found that sometimes even when I am driving if I press the unlock button it has no effect.

Before I book it into a dealers to have a look at has anyone come across a similar problem and been able to resolve it? 

Thanks in advance

Ade

I had a problem with mine like this, sometimes it wouldnt unlock at all, took it to Subaru who fixed it even out of warranty, suggesting it was a known fault, might be worth speaking to your dealer?

Share this post


Link to post
Share on other sites

Cheers Dogconker I'll give them a call and get them to have a look at it..

 

Share this post


Link to post
Share on other sites

So an update on this one, The fault got worse with now only the drivers door opening from the outside with the key. I have had it to my local dealer who initially thought it was the master door locking mechanism that had faulted, they replaced it and it made no difference. So now working with Subaru techs they have determined that it is the Body Control Unit Module that has gone faulty and they have recommended replacing it.  Let's see if this works!

 

Share this post


Link to post
Share on other sites

Update So they have replaced the Body Control Module and all doors are now working fine..

Share this post


Link to post
Share on other sites

Glad you managed to get it sorted,  this type of fault can be both worrying and frustrating.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, ade said:

Update So they have replaced the Body Control Module and all doors are now working fine..

Good result

  • Like 1

Share this post


Link to post
Share on other sites
On 4/5/2018 at 11:14 PM, Dogconker said:

Good result

I have a similar issue with my 2013 XV. The local garage have replaced the drivers door lock unit but we still have the issue! Thanks for posting this info. Can you remember how much the new unit wit fitting cost??

Share this post


Link to post
Share on other sites
On 5/13/2019 at 8:21 PM, Graham S said:

I have a similar issue with my 2013 XV. The local garage have replaced the drivers door lock unit but we still have the issue! Thanks for posting this info. Can you remember how much the new unit wit fitting cost??

Sorry only just seen this, hopefully you have got it sorted but if not, it cost about £1k but they discounted the part by 25% as  it was only just out of warranty.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...