moshe_levy

Members
  • Content Count

    97
  • Joined

  • Last visited

  • Days Won

    2

moshe_levy last won the day on September 15 2018

moshe_levy had the most liked content!

Community Reputation

11 Good

About moshe_levy

  • Rank
    Advanced Member

Profile Information

  • Location:
    israel
  • Subaru Model
    subaru forester XT 2008

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I also didn't buy OEM hoses by the time I replaced mine, just put 3mm silicon hoses between the T and the wastegate/bcs, than from that 3mm hose you should get connector that goes from 3mm to 6mm and from there to the bcs with 6mm hose. The same I did with the hose that goes back to the intake, 6mm hose the connector the other side is I think 4mm (that what I put,don't think it matters what size the air going back to intake) than another connector from 4mm to 6mm again. Hope you understand me. Sent from...somewhere
  2. The stock bcs working great but it's up to you goals, where do you want to go from there. About the fuel level try to open the fuel pump under the back seat get it out of the gas tank and see what's going on with the gas buoy. I think the problem might be there. Sent from...somewhere
  3. You should connect the turbo hose in T splitter, one side to the wastegate and the other to the bcs. But pay attention, inside the hose that goes from the turbo to the T should be restrictor pill. What size to your car exactly I don't know you have to check it. Sent from...somewhere
  4. As long as i can see it's fit my car as well... Sent from my SM-G955F using Tapatalk
  5. I have the sg model 06-08, (08). What is the lolly pop? Like ball joints? Sent from my SM-G955F using Tapatalk
  6. I have a problem with the whiteline end links after installed and lowering with tein coils. Sims to me that the end links both side touching the tie rod. Like they made some rooling to the front of the car and now it is rubing against the tie rod. What did i do wrong? Sent from my SM-G955F using Tapatalk
  7. With tein coils.... Sent from my SM-G955F using Tapatalk
  8. If it's 5×100 it will fit. Sent from my SM-G955F using Tapatalk
  9. New wheels 18×8" 225 45, what do you think? Sent from my SM-G955F using Tapatalk
  10. Here is the new witheline end links, tell me please where i'm wrong or everything is install fine. Both sides, something looks to me weird on the left one. Looks lkke the bushing wants to come out. Sent from my SM-G955F using Tapatalk
  11. Here is the moog end links that i just pulled out, i'm very disappointed from them. I will install whiteline and post pictures. Sent from my SM-G955F using Tapatalk
  12. Mine also has bosh sensor with preheating ( i can see on the led screen it's written "heating"). I installed it something like 40 c"m from the turbo on the 6 o'clock. And as far as i know there is no leaks from the exhaust. Now on WOT i should look only on the aem and not the oem one that stops working on 11.2 and the dyno one that measure the gases from the back of the rear muffler m i right? Sent from my SM-G955F using Tapatalk
  13. Sorry if this the wrong forum, i just installed the AEM X series wideband, and it seems to run reacher than the stock which i see with the obd2. On idle the aem shows for instance 14.60 and the obd2 shows 14.75-14.8. Which is accurate? Thanks Sent from my SM-G955F using Tapatalk
  14. moog just failed me so i don't think i will go with them again. Sent from my SM-G955F using Tapatalk
  15. Hello My car is forester 2008 xt 4eat. I bought my car 2 years ago and been to the usa at that time so i purchas there front and rear end links and lower ball joints. Now it has been ayear and half and one ball joint failed and the two front end links failed, all of the place full with grease. Is there any reason for that, should i buy now only oem parts? Thanks Sent from my SM-G955F using Tapatalk