Jump to content

Pitch torque solution


moshe_levy
 Share

Recommended Posts

Hello

I just instal yestarday the torque solution,gears transfer smoothly and the pitch angle is much less but....i have more sound from the gear like i don't have noise insolation any more. ( my car is 2008 xt forester auto trans) it's not like it bacomes new sound but the regular sound of the gear/ engine sounds harder inside the car.

Maybe there is a leak from the intercooler since i didn't put back the pipes well or the sound supposed to be because of this tough bushings?

Is it good or bad to the trans?

Thanks guys

Sent from my SM-N910F using Tapatalk

523c4f2635e65bf06c9e0f23f71fa756.jpg

a4e6bcfcce277fc41d6181807b8baa40.jpg

963d36abdc8abb7479f854321f7d32ce.jpg

Link to comment
Share on other sites

Ever since i installed the pitch torque i feel that the car is not like it should be it's drive less good the boost is only 0.4 bar by the OBD2 conector that connect to my phone.

What could be the connection between those two?

Sent from my SM-N910F using Tapatalk

Link to comment
Share on other sites

You could have disrupted the ic pipework and it's now leaking I'd check to see if you missed tightening a hose clamp, (easy enough to do, I have before)

Or maybe one of the earth straps under the cooler

Sent from my SM-G930F using Tapatalk

Link to comment
Share on other sites

The gasket from the oem ic does not feet to the upgrade ic so i'm waiting the aftermarket gasket to arrive but i put some one home made meanwhile.

I think i'm hearing the leak when i drive the car but can not realy check where it come from.

Sent from my SM-N910F using Tapatalk

Link to comment
Share on other sites

I checked today and didn't find any leaks.

I consult some mechanic that built some wrx and sti,so he asked me if i changed the vacum pipe that goes from the turbo to the T and from there one goes to the boost controler and one to the wastegate.

Now this little vacum pipe has nozle inside it to build the boost.

I changed this vacum pipe to some silicon regular one and acording to what he saied this cause the low boost.

Someone hear about this pipe with anozle inside it?

Sent from my SM-N910F using Tapatalk

Link to comment
Share on other sites

I think it it's .09mm stock I could be wrong though, there are 3 different sizes depending on year,

Thierry one above should set boost thershold at 0.9bar .

Best off either contacting your dealer and quote your vin number and they will be able to supply you one, they are quite cheap.

Sent from my SM-G930F using Tapatalk

Link to comment
Share on other sites

Hi every one i changed back to the original restrictor pill the boost is on again but now it become another issue...[emoji45], when i'm on boost the boost gauge and the rpm is up and down up and down....when i'm not on boost every thing is smooth.

1.any one has an idea?

2.the restrictor is supposed to be from the outlet of the turbo to T than 1 goes to the wastgate and one to the boost controler,the size of the hose with the pill inside is small like 5-7 cm,it should be like that or i should extend it?

Thanks.

Sent from my SM-N910F using Tapatalk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...




Forums


News


Membership