Jump to content

Seminole81's 2006 Widetrack STi Build


Seminole81
 Share

Recommended Posts

Hi everyone! Little bit of background info on me for those that missed my introduction post in the new members section. My name's Steve, and I live in the lovely North East in the Tyne and Wear area. I'm originally from the States and always been into cars, especially Japanese ones, although I do still appreciate the old American classic muscle cars.'69 Camaro or Charger anyone? I was pretty big into Honda's and built with my friends a pretty decent motor. I even had a 2005 Honda 600RR. Unfortunately, I moved here about 7 years ago to be with my now wife (who's awesome by the way for letting me get this haha) before I could get it up and running.

Anyways, I've finally got my first Scoobie, a 2006 STi. Absolutely love it! Overall, fairly good condition, few little stone chips scratches, but it's a 10 year old car in pretty good nick all in. It's a Type UK imported from Singapore with a full service history, and a few little mods like a Zero Sports intake and radiator, DEFI gauges, etc.

Original sale listing:

http://jm-imports.co.uk/index.php/2006-subaru-impreza-gdb-sti-widetrack-6-speed-manual/

And some pics since I picked her up:

IMG_3025.JPG

IMG_3023.JPG

IMG_3024.JPG

IMG_3021.JPG

IMG_3022.JPG

IMG_3010.JPG

IMG_3008.JPG

IMG_2984.JPG

Overall, haven't done too much yet to her as funds are a bit limited now, but I do have some plans in mind.

Things done already:

Taken gauges off the awful rack (see the original listing photos) they had and had JM put in the triple centre hood and a twin A pillar pods. Although I'm not overly happy with this as they've screwed it on at the top!

Current issues?

Heat doesn't seem to work all the time even after warming up? Maybe faulty heater core, although noticed the fans on the centre console pop out easily and don't click in.

Gearbox groans a bit at full lock turns, read this is normal?

Noisey interior road noise, again read this is normal?

Pretty squeaky when going over speed bumps

MPG really low at moment, but still getting use to car so might be ok

Current near future plans:

Upgrade head unit and speakers as current are stock

Wind Deflectors (anyone got these? Still torn on if I want them)

Fog light covers

STi floor mats, current are rubber and feet slide all over on them!

Try and clean up interior a bit more (leftover sticky goo stuff where old gauges were mounted, clean seats and headliner properly etc.)

Rid of awful switch that does nothing?

Touch up paint with OEM pen? Anyone experience with one?

Future plans, maybe:

Suspension mods (roll bars, etc.)

New alloys (totally undecided on these at moment, want something nice like Volk maybe?)

Front lip, maybe a rear lip too

Snowboard roof rack? Think these look cool.

Debating on springs or coilovers

Fully decat exhaust

Fuel pump (already has FPR so might have this?)

Forge engine

New spark plugs

Front mount intercooler

Bigger turbo

Bigger injectors

Full tune

Full respray?

 

Think that's about everything I can think of for now!

  • Like 1
Link to comment
Share on other sites


26 minutes ago, Jay762 said:

Sounds like a plan :thumbsup:

If the fuel pump is more than five years old it is worth considering a replacement particularly if you are going for a turbo injector upgrades and the associated remap

Yeah. I'm just curious to as if it's maybe already been done like I said as it's for a SARD FPR. Would have to take it apart to find out, something I don't particularly want to do at this time of the year haha, hence why the current plans are nice little easy bits. 😊😉

Link to comment
Share on other sites

22 minutes ago, Tidgy said:

heaters not working could be a sign of headgasket issues.

Could be a few different things, but I doubt that's one of them? Temp sensor, heater core (matrix or whatever you want to call it), radiator are all first to check. System might just need flushed. Luckily I've got the warranty and have been in touch with JM over it.

Link to comment
Share on other sites

28 minutes ago, Seminole81 said:

Could be a few different things, but I doubt that's one of them? Temp sensor, heater core (matrix or whatever you want to call it), radiator are all first to check. System might just need flushed. Luckily I've got the warranty and have been in touch with JM over it.

Could be various things, but given its a 2.5 get ti checked out by a specialist who's independent of the seller.

Link to comment
Share on other sites

15 minutes ago, kershaw-330s said:

 

Has wrx bumper emoji52.png

 

Sent from my Nokia 3310 using Tapatalk

bumper is the same on sti and wrx, some have lip spoilers and sti typicly has no fogs, although fogs were an option. Only difference is the inserts

  • Like 1
Link to comment
Share on other sites

45 minutes ago, kershaw-330s said:

 

I allways thought you couldn't get fogs on sti , I know on blobs fogs are not even an option except on wr1s

 

Sent from my Nokia 3310 using Tapatalk

Can retrofit if you want plus eurospec have them as some countrys have to have by law them so i understand.

  • Like 2
Link to comment
Share on other sites

What Tidgy said from my Googling haha. It's definitely a STI as I checked the VIN.

2 hours ago, Tidgy said:

Could be various things, but given its a 2.5 get ti checked out by a specialist who's independent of the seller.

True. Going to for sure. I think it might be the thermostat if I'm honest. Cars from Singapore where it's always hot, leave thermostat open/bypass/take off whatever, keep car cool all the time and no need for heat. 

Link to comment
Share on other sites

So I threw a CEL over the weekend, didn't think it was anything major, but she was misfiring and didn't really wanna go. I thought after extensive googling as I don't own a reader, yet, it was a probably a plug or coil pack. Spoke with JM and he said to bring it back up today and we'd get it sorted so I did. Coil pack clip went, JM fixed it and she's running great again. Had a cheeky stop on the way home, filled up with V-Power and swung by the Gateshead quays for a quick photo op. Here's what I few got 😊😍

IMG_3083.JPG

IMG_3088.JPG

IMG_3089.JPG

IMG_3090.JPG

Link to comment
Share on other sites

3 minutes ago, Tidgy said:

http://asperformance.com/

 

isn't a million miles from newcastle, I'm not sure if they do general service work, but well worth a call to find out or get a recommended local place, Alyns a decent guy

Never heard of them! But they're literally around the corner from where I live 😂 Will give them a ring 😊

Link to comment
Share on other sites

Had it checked over, basically same as what JM did for me. All looks good. Need to find a place to stick it on a dyno though.

Latest saga is the rear defrost stopped working. No light or relay click. Checked the fuse, which looked a bit scorched so I replaced it. Didn't fix it. Guessing it's the relay that faulty now. JM is going to fix it for me which is good.

Has anyone done the LEDs on the climate controls? Debating on what to do as I've got the red speedo, green climate, and white DEFIs...should I make climate red? Leave it as is? Which LEDs did you buy if you've done it?

Link to comment
Share on other sites

3 minutes ago, Jay762 said:

looking on the positive it is not the rear window element that is faulty so you have a loose connection somewhere

Yep, that's what I was thinking...either that or the fuse was actually gone and it just took a few to reset it 🤔

Link to comment
Share on other sites

Cuvva - A better way to insure your car

Pay monthly without the interest. 0% APR. No deposit, no hidden fees.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...




Forums


News


Membership