stants

What have you done to your Subaru today ?

Recommended Posts

904d656be01e4f99c29326459b62b187.jpg&key=7fbc20c51a29a9b60007065e65b8723ce47688fa3b134f37ec1b644b65b19f09


Sent from my iPhone using Tapatalk
Is that a kit? Or did you just order what you needed?

Sent from my SM-G960F using Tapatalk

Share this post


Link to post
Share on other sites
 

904d656be01e4f99c29326459b62b187.jpg&key=7fbc20c51a29a9b60007065e65b8723ce47688fa3b134f37ec1b644b65b19f09


Sent from my iPhone using Tapatalk
Is that a kit? Or did you just order what you needed?

Sent from my SM-G960F using Tapatalk

Share this post


Link to post
Share on other sites

I ordered kits
Totalled just shy of £900 for all the hoses

There’s a few that haven’t been changed yet but will eventually get round to doing so.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I fitted some hella horns with a grimspeed bracket


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Looking good mate, you'll probably have people asking if they're the turbo like i did

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

Broke a wheel and a tire
!Removed! space saver wouldn’t fit over the callipers
Luckily I had a spare wheel 30miles away at home



Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Feeling pretty jealous

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

Air filter, engine flush, Oil, Oil filter, spark plugs and fuel filter done today

1B24BBD4-0267-411A-A0A8-5E584DC9DE2F.jpeg

Share this post


Link to post
Share on other sites
On 5/4/2018 at 10:08 AM, kershaw-330s said:

How cool is that 🤘🏼 Got an inside man on the forum 👍🏼

How’s your Titan Race pros S going since you put it in? Is it performing well? 

Share this post


Link to post
Share on other sites

Well, I broke it. 2 days in 😂

Had a slight issue with the temperature fluctuating, rising slightly under boost. Assumed the previous owner just hadn’t bled the system properly and the dive home had shown it up better than his 15 minute drive to work... 

Anyway, took the cap off the header tank to check the level, to find I had the top half of the cap in my hand and the rest sat in the top of the tank. At least it explains the issue... 

Coolant change with new caps and thermostat and oil change is now my job for the weekend! 

  • Like 1

Share this post


Link to post
Share on other sites

Glad to hear found the problem

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

forgot to update this the other day, engine started knocking, so its sat in the corner of the yard feeling sorry for its self till im back from working away, flipping cars eh.

i guess on the plus side, its and excuse to play some more with it. "Cheaper than buying another car...." is the line i've used on the wife and she seems to have gone with it, so we will see what happens

  • Like 1

Share this post


Link to post
Share on other sites

 

Sorry to hear that the the bottom end has gone 😕

but sounds like you'll end up with a nice reliable new one , instead of gambling on another 2nd hand engine or car ,mattie 😉😈😂

Hope the header cap and fluids sort the temp trouble sam 👍

Had some snow today , first time the v1sti hasn't been out in it ,she's still sleeping 😏 

Share this post


Link to post
Share on other sites

Gutted not got a scoob if it snows..

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites
46 minutes ago, Gambit said:

Gutted not got a scoob if it snows.. emoji17.png


 

I was scoob'less for a few of the spring and early summer months last year ,so sorta know what your saying 🙄

 

But today I just took the bug out instead 🤐😊

  • Like 1

Share this post


Link to post
Share on other sites
I was scoob'less for a few of the spring and early summer months last year ,so sorta know what your saying
 
But today I just took the bug out instead
Its the empty car parks i miss

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

Decided it was too cold to mess about with the coolant today, so topped it up and replaced the radiator caps. All seems well, got her up to temp and took her for a spin, temp gauge sits bang on. 

Love this thing 

95E15A87-4250-4F2E-BA3E-F27B1EC99033.jpeg

  • Like 2

Share this post


Link to post
Share on other sites

I so want another one i can't wait especially when i see the snow this morning. The little puma isn't the same in this weather

Sent from my SM-G950F using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now